Whats going on here?!?!?! my still is acting weird

Post your builds here.

Moderator: Site Moderator

Locked
nzl.james
Novice
Posts: 20
Joined: Sun Mar 06, 2011 1:20 am

Whats going on here?!?!?! my still is acting weird

Post by nzl.james » Tue Jun 14, 2011 9:21 pm

Ok,
new5.jpg
So ive pretty much finished my still and decided to do a water run through it to make sure the reflux condenser was long enough that alcohol doesnt escape out the top heres what I did:

Filled the keg with water and turned both elements on (1500w and 2000w)

put the column on (valve open) and started the cooling water, running into the bottom of the product condenser, out the top then into the reflux condenser, then down the drain

once the water started boiling, steam started pouring out the top of the column, which is completely uncovered 3in tube, no cap. nothing at all came out thetakeoff


cooling water was cold when exiting
new1.jpg
i stuffed my reflux condenser with pot scrubbers and tried again. this time nothing came out the top of column or product condenser
new7.jpg
this is the height the condenser sits in the top, the bottom is about 1 column width (80mm/3inches) from top of takeoff
new8.jpg

I turned down the flow of the cooling water, then steam started coming out the top of the column AND out the product condenser. when i turn the coolant flow back up nothing comes out the top or the product condenser again.

It seems to be acting like a CM still.

WHATS GOING ON??? PLEASE HELP

rad14701
Master Distiller
Posts: 20866
Joined: Wed Dec 19, 2007 4:46 pm
Location: New York, USA

Re: Whats going on here?!?!?! my still is acting weird

Post by rad14701 » Wed Jun 15, 2011 5:04 am

This issue was properly answered in the original topic so this one is being closed...

Locked